Service disruption: Plaza & Checkout
Incident Report for Buckaroo
Postmortem

Monday the 12th of December we’ve experienced two unexpected partial outages affecting one of our database clusters. Due to this issue our transaction processing system and payment plaza showed degraded performance.

The additional safeguards implemented after our outage in November unfortunately didn’t prevent this issue, but it did help us to pinpoint the root cause of the issue.

The incident was caused by a software bug which in some edge case caused locks in our database cluster.

Tuesday the 13th in the afternoon a fix has been released and rolled out to all our production systems.

Posted Dec 15, 2022 - 10:35 CET

Resolved
This incident has been resolved.
Posted Dec 12, 2022 - 15:53 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 12, 2022 - 15:26 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 12, 2022 - 14:55 CET
This incident affected: Services & Apps (Plaza).