External outage: Belfius

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Jul 06, 2025 - 13:23 CEST

Identified

Belfius is experiencing an outage. The source of the disruption is external to Buckaroo.
We will provide updates as they become available.
Posted Jul 06, 2025 - 12:23 CEST

Investigating

We're experiencing a lower success rate for this service than usual.
Posted Jul 06, 2025 - 12:09 CEST
This incident affected: Payment methods (Belfius).