POS Terminal Disruption

Incident Report for Buckaroo

Postmortem

On the evening of 22 July 2026, between approximately 19:11 and 20:09 CEST, a technical issue on our payment platform affected transaction processing for POS (in-store) terminals. During this period, affected terminals were temporarily unable to complete payment transactions.

This disruption only affected Buckaroo terminals. Other terminals were not affected.

The cause was a technical issue on our side. It has been fully identified and resolved, and POS transaction processing has been operating normally since 20:09 CEST.

We have also put additional monitoring measures in place to prevent this from recurring.

We sincerely apologise for the disruption and any inconvenience this caused.

Posted Jul 24, 2026 - 09:20 CEST

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 20:55 CEST

Monitoring

Between 19:11 and 20:09 (CEST), an issue affected payments processed via POS terminals. This has been resolved and we are currently monitoring the situation.

We are still investigating the root cause and will provide a follow-up once this has been determined.

We apologize for any inconvenience caused.
Posted Jul 22, 2026 - 20:29 CEST
This incident affected: Point of Sale (Processor).