Plaza transaction overview: Delayed visualization

Incident Report for Buckaroo

Resolved

This issue has been resolved. All transactions are now visible in the transaction overview.
Posted Jan 09, 2026 - 11:49 CET

Identified

A fix has been implemented, and transactions of this month are currently being reloaded into the transaction overview.
Posted Jan 09, 2026 - 11:07 CET

Investigating

Today's transactions or statuses may not be shown in the transaction overview. Transaction processing is not affected. We're currently investigating this issue and will provide updates as they become available.
Posted Jan 09, 2026 - 10:03 CET
This incident affected: Services & Apps (Plaza).