External - Degraded success rate iDEAL: Disruption at ABN AMRO
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Jul 01, 2024 - 17:32 CEST
Investigating
We're experiencing a lower success rate for this service than usual. This is due to a disruption at ABN AMRO
Posted Jul 01, 2024 - 17:03 CEST
This incident affected: Payment methods (iDEAL).