Service disruption: Plaza
Incident Report for Buckaroo
Resolved
Recent historical transaction data has been restored. Further data will be gradually restored over the coming days.
Posted Sep 13, 2023 - 17:12 CEST
Update
Downloading of payout reports and financial statements is now possible. Historical transaction data is currently being loaded into the Plaza in reverse chronological order. For older transactions, it is possible that they do not yet show up when searching in the transaction overview.
Posted Sep 13, 2023 - 13:39 CEST
Identified
Some pages in the Plaza, such as the transaction overview, might not show up-to-date information. Downloading of payout reports and financial statements is currently not possible.

We will provide updates as they become available.
Posted Sep 13, 2023 - 06:29 CEST
This incident affected: Services & Apps (Plaza).