Service disruption: Plaza
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Jan 09, 2023 - 18:00 CET
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 09, 2023 - 17:00 CET
Investigating
Our service monitoring has detected an issue with the transaction overview. Recent transactions are possibly not shown in the Buckaroo Payment Plaza.

This does not affect transaction traffic.
Posted Jan 09, 2023 - 15:00 CET
This incident affected: Services & Apps (Plaza).