Service disruption: iDEAL

Incident Report for Buckaroo

Resolved

The issue has been fully resolved. Contact with iDEAL has confirmed that the issue was caused externally, affecting multiple banks/acquirers. We've been informed that the cause of the issue was reverted and measures have been taken to prevent recurrence.
Posted Nov 05, 2025 - 19:36 CET

Monitoring

The issue has been resolved externally. We will continue to monitor the situation.
iDEAL payments between 18:15 and 18:35 were affected by the outage.

PS: Payments via other iDEAL-acquirers via our platform may still be affected.
Posted Nov 05, 2025 - 18:55 CET

Investigating

Our service monitoring has detected an outage. We're investigating the issue.
Posted Nov 05, 2025 - 18:29 CET
This incident affected: Payment methods (iDEAL).