External - Degraded success rate iDEAL: Full disruption at ING
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Jun 10, 2024 - 09:32 CEST
Investigating
We're experiencing a lower success rate for this service than usual. This is due to a disruption at ING
Posted Jun 10, 2024 - 09:08 CEST
This incident affected: Payment methods (iDEAL).