The scheduled maintenance has been completed without any disruptions to our services.
Posted Nov 09, 2023 - 08:04 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 09, 2023 - 07:00 CET
Update
The Bancontact service also falls within the scope of Cards services, and has been added as a component of this scheduled maintenance. Apologies for the inconvenience in communication.
As previously stated, we will be undergoing scheduled maintenance during the specified time. We do not anticipate any disruptions to the Cards service during this maintenance.
Posted Nov 07, 2023 - 13:49 CET
Update
-
Posted Nov 07, 2023 - 13:00 CET
Scheduled
Maintenance Start: Thursday, 09.11.2023 07:00 CET Maintenance End: Thursday, 09.11.2023 08:00 CET
We will be undergoing scheduled maintenance during this time. We do not anticipate any disruptions to the card service during this maintenance.
Posted Nov 07, 2023 - 11:53 CET
This scheduled maintenance affected: Payment methods (Bancontact, Mastercard, Visa, AMEX, Apple Pay).