External disruption iDEAL - SNS, ASN and Regiobank

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Feb 24, 2025 - 15:53 CET

Identified

SNS, ASN and RegioBank are experiencing a disruption on their side which affects iDEAL payments. We will closely monitor the situation.

https://availability.ideal.nl/incidents/yc550xgy4xkt
Posted Feb 24, 2025 - 14:14 CET
This incident affected: Payment methods (iDEAL).