EXTERNAL - Degraded success rate: KBC Payment Button
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Jan 19, 2024 - 11:44 CET
Identified
We're experiencing a lower success rate for this service than usual. KBC is aware of the issue and is working on a solution.
We will share updates as they become available.
Posted Jan 15, 2024 - 11:02 CET
This incident affected: Payment methods (KBC Payment Button).