External partial outage: iDEAL - ING
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 11:58 CET
Identified
iDEAL issuer ING was experiencing a full outage. iDeal payments via this bank were (largely) not possible from approximately 10:31 to 10:52 CET.

The outage seems to be partially resolved, but customers could possibly still experience issues during the payment process.
Posted Mar 21, 2023 - 11:03 CET
Investigating
We're experiencing a lower success rate for this service than usual.
Posted Mar 21, 2023 - 10:52 CET
This incident affected: Payment methods (iDEAL).