POS payouts delayed for My Buckaroo customers
Incident Report for Buckaroo
Resolved
All payouts have now been processed.
Posted Jun 24, 2024 - 13:17 CEST
Identified
There is a delay for this morning's POS-Terminal payouts. This pertains specifically to transactions in the My Buckaroo portal.

We are working on a solution to make the missing payouts available as soon as possible. Updates will follow shortly.
Posted Jun 24, 2024 - 08:39 CEST
This incident affected: Point of Sale (Buckaroo Processor).