Delay in the payouts for POS Portal merchants
Incident Report for Buckaroo
Resolved
The issue has been resolved. All delayed payouts have now been processed.
Posted Oct 19, 2024 - 09:15 CEST
Identified
We are investigating an issue which is causing a delay in today's payout to POS Portal merchants (my.buckaroo.nl). We expect that today's payout (19/10/2024) be settled before 13:00.
Posted Oct 19, 2024 - 08:19 CEST
This incident affected: Point of Sale (Buckaroo Processor).