Missing invoice PDF for Buckaroo invoices

Incident Report for Buckaroo

Resolved

The issue has been found and resolved. However, we are unable to resend the PDF's for the affected Buckaroo invoices. The merchants impacted by this issue have been notified by email with instructions on how to download the PDF's.
Posted Oct 03, 2025 - 10:27 CEST

Investigating

We have detected issues with Buckaroo's invoices sent to our merchants. The invoice PDF may be missing in the attachments. We are investigating this issue.
Posted Oct 02, 2025 - 16:15 CEST
This incident affected: Services & Apps (Plaza).