External disruption: iDEAL (ING)
Incident Report for Buckaroo
Resolved
This incident has been resolved. It will be investigated further externally.
Posted May 25, 2024 - 09:13 CEST
Monitoring
Between approximately 9:15 and 10:25 CEST, we experienced a disruption with IDEAL payments via ING. The issue was related to a delay in status updates. During this period users may have noticed delays in conformations for iDEAL payments via ING. This issue seems to be resolved. We will investigate it further and keep monitoring.
Posted May 24, 2024 - 11:02 CEST
This incident affected: Payment methods (iDEAL).