Outage: iDEAL
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Oct 09, 2024 - 11:40 CEST
Monitoring
Between approximately 10:20 and 11:20 CEST, we experienced an outage with IDEAL payments. This issue is resolved and success rates are back to normal. We will keep monitoring the situation.
Posted Oct 09, 2024 - 11:33 CEST
Investigating
We are currently investigating this issue.
Posted Oct 09, 2024 - 10:29 CEST
This incident affected: Payment methods (iDEAL).