Degraded success rate: Mastercard

Incident Report for Buckaroo

Resolved

The issue is resolved
Posted Jul 15, 2026 - 10:26 CEST

Identified

External: We have identified a full disruption external to our platform affecting card payments.
You will see a decline in successful payments as consumers will be unable to pay using their MasterCard card.
Posted Jul 15, 2026 - 09:25 CEST
This incident affected: Payment methods (Mastercard).