Delay in the payouts for POS Portal merchants
Incident Report for Buckaroo
Resolved
This incident has been resolved. All payouts have been processed.
Posted Sep 08, 2024 - 15:37 CEST
Investigating
We are investigating an issue which is causing a delay in today's payout to POS Portal merchants (my.buckaroo.nl)
Posted Sep 08, 2024 - 08:55 CEST
This incident affected: Point of Sale (Buckaroo Processor).