EXTERNAL: Degraded success rate: Mastercard

Incident Report for Buckaroo

Resolved

The incident has been resolved
Posted Jul 15, 2026 - 14:34 CEST

Identified

A certificate has expired. We are working on resolving this issue
Posted Jul 15, 2026 - 12:13 CEST

Investigating

External: We have identified a full disruption external to our platform affecting card payments.
You will see a decline in successful payments as consumers will be unable to pay using their MasterCard card.
Posted Jul 15, 2026 - 12:13 CEST
This incident affected: Payment methods (Mastercard).