External: Degraded success rate: Afterpay

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Nov 16, 2022 - 12:25 CET

Update

We are continuing to investigate this issue.
Posted Nov 16, 2022 - 08:45 CET

Investigating

We're experiencing a lower success rate for this service than usual.
Posted Nov 16, 2022 - 01:00 CET
This incident affected: Pay Later Services (Riverty).