External: Degraded success rate Belfius
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Nov 19, 2022 - 01:00 CET
Identified
There is an outage at Belfius
Posted Nov 18, 2022 - 18:34 CET
Investigating
We're experiencing a lower success rate for this service than usual.
Posted Nov 18, 2022 - 18:31 CET
This incident affected: Payment methods (Belfius).