External disruption: Paypal
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 23:33 CEST
Monitoring
Paypal is experiencing a system issue that resulted in a lower success rate for Paypal payments between approximately 20:50 and 21:57 CEST.

Their technical teams are actively working towards resolving the issue; the success rates already seem to be back to normal. We will monitor the situation.
Posted Oct 16, 2024 - 22:16 CEST
This incident affected: Payment methods (Paypal).