External - Degraded success rate iDEAL: Partial disruption at Rabobank
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Jul 05, 2024 - 20:15 CEST
Investigating
We're experiencing a lower success rate for this service than usual. This is due to a disruption at Rabobank.
Posted Jul 05, 2024 - 19:51 CEST
This incident affected: Payment methods (iDEAL).