External outage: PayPal
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Feb 11, 2024 - 14:20 CET
Investigating
We're experiencing a lower success rate for this service than usual. There seems to be a partial outage at Paypal since approximately 13:15 CET.
We will provide updates as they become available.
Posted Feb 11, 2024 - 13:43 CET
This incident affected: Payment methods (Paypal).