Disruption Buckaroo terminals

Incident Report for Buckaroo

Resolved

The issue has been resolved.

Earlier we have sent the wrong information through email regarding the POS outage. Only Buckaroo terminals were affected by the outage.

Apologies,
Team Buckaroo
Posted Jun 04, 2025 - 15:10 CEST

Monitoring

The issue has been resolved. We will continue to monitor the situation.
Posted Jun 04, 2025 - 14:24 CEST

Investigating

We are currently experiencing an outage with our POS service. All PIN transactions are currently failing. We are working on a solution and will keep you updated.
Posted Jun 04, 2025 - 14:17 CEST
This incident affected: Point of Sale (Processor).