Full External service disruption Giropay transactions via PPRO
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted May 31, 2024 - 10:56 CEST
Identified
We're experiencing a lower success rate for this service than usual.
Posted May 31, 2024 - 10:51 CEST
Investigating
We are currently investigating this issue.
Posted May 31, 2024 - 10:50 CEST
This incident affected: Payment methods (Giropay).