External service disruption: iDEAL

Incident Report for Buckaroo

Resolved

We have observed a recovery of the success rate of iDEAL transactions, and iDEAL has reported that the incident has been resolved.
Transactions between 09:45 and 10:15 were potentially affected by this outage.
Posted Dec 05, 2025 - 10:28 CET

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 10:13 CET

Investigating

We have identified an external full disruption affecting iDEAL payments.
As a result, customers may experience difficulties when attempting to complete payments via iDEAL.
Posted Dec 05, 2025 - 10:12 CET
This incident affected: Payment methods (iDEAL).