Degraded performance: Login issues my.buckaroo.nl

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Oct 04, 2024 - 12:43 CEST

Identified

Two-factor authentication emails are not sent to users.
Posted Oct 04, 2024 - 10:15 CEST