Belfius payments disruption

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 22:29 CEST

Investigating

We are currently experiencing a disruption affecting Belfius payments. Since around 10:35 today, Belfius payments are failing and customers cannot complete them.
Posted Aug 12, 2026 - 15:19 CEST
This incident affected: Payment methods (Belfius).