iDEAL external disruption: Rabobank

Incident Report for Buckaroo

Resolved

This incident has been resolved. iDEAL success rates via Rabobank were affected between approximately 20:55 - 21:20 CET.
Posted Mar 27, 2025 - 21:39 CET

Identified

There is an issue with the availability of Rabobank. Users of Rabobank could experience issues when paying with iDEAL.
Posted Mar 27, 2025 - 21:12 CET
This incident affected: Payment methods (iDEAL).