External Service disruption: PayPal

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 19:00 CEST

Investigating

We are currently experiencing a full outage with the PayPal payment method. The issue originates on PayPal’s side.
Posted Oct 16, 2025 - 17:32 CEST
This incident affected: Payment methods (Paypal).