Degraded success rate: External disruption iDEAL(ABN AMRO)
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 11:08 CET
Identified
ABN AMRO is experiencing a disruption on their side which affects iDEAL payments. We will closely monitor the situation.
Posted Jan 22, 2025 - 11:05 CET
This incident affected: Payment methods (iDEAL).