Payouts 01-02-2024 and statements 31-01-2024
Incident Report for Buckaroo
Resolved
This incident has been resolved. All daily payouts and statements are now visible in the Plaza and the corresponding reports are available for downloading.
Posted Feb 01, 2024 - 14:20 CET
Investigating
Today's payouts are not yet generated. Furthermore, yesterday's account statements are not yet visible in the Plaza. The underlying issue is known and we're working on making the payouts available as soon as possible.

We will inform you once we have an update.
Posted Feb 01, 2024 - 09:55 CET
This incident affected: Services & Apps (Payouts).