Delayed POS payouts

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Sep 19, 2026 - 11:38 CEST

Investigating

We are currently experiencing a delay affecting today's POS payouts.

We are actively investigating and are working to resolve this as quickly as possible. A further update will follow as soon as more information is available. We apologize for any inconvenience.
Posted Sep 19, 2026 - 09:33 CEST
This incident affected: Services & Apps (Payouts).