External service disruption: iDEAL Rabobank

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 13:51 CEST

Monitoring

As of approximately 12:50 CEST, the issue at Rabobank seems to be fully resolved. We will monitor the situation.
Posted Sep 02, 2026 - 13:13 CEST

Identified

There is an issue with the iDEAL availability of Rabobank since approximately 11:25 CEST. Users could experience issues when paying with iDEAL.

We will provide updates as they become available.
Posted Sep 02, 2026 - 12:20 CEST
This incident affected: Payment methods (iDEAL).