Login issues in Plaza

Incident Report for Buckaroo

Resolved

The issue has been resolved.
Posted Feb 24, 2026 - 13:25 CET

Identified

Users are currently unable to log into the Buckaroo Plaza.
We are working on resolving this issue.
Posted Feb 24, 2026 - 12:34 CET
This incident affected: Services & Apps (Plaza).