Belfius - maintenance (external)

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Jun 15, 2025 - 14:31 CEST

Identified

Belfius has to perform maintenance in its systems that will affect its availability for Belfius.
Posted Jun 15, 2025 - 09:44 CEST

Investigating

We're experiencing a lower success rate for this service than usual.
Posted Jun 15, 2025 - 09:28 CEST
This incident affected: Payment methods (Belfius).