Degraded success rate: Payconiq
Incident Report for Buckaroo
Resolved
This incident has been resolved.
Posted Sep 12, 2024 - 11:26 CEST
Update
We are continuing to investigate this issue.
Posted Sep 10, 2024 - 16:39 CEST
Investigating
We're experiencing a lower success rate for this service than usual.
Posted Sep 10, 2024 - 16:38 CEST
This incident affected: Payment methods (Payconiq).