Major outage online Credit Cards & Tap to Pay

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Aug 10, 2026 - 11:03 CEST

Monitoring

The issue has been resolved and all services are fully operational. We will continue to monitor the situation.
Posted Aug 10, 2026 - 10:46 CEST

Update

We are continuing to investigate this issue.
Posted Aug 10, 2026 - 10:37 CEST

Update

We are continuing to investigate this issue.
Posted Aug 10, 2026 - 10:37 CEST

Investigating

We are currently experiencing an issue affecting our online Credit Card services and Tap to Pay. This is being investigated with the highest priority.
Posted Aug 10, 2026 - 10:36 CEST
This incident affected: Payment methods (Mastercard, Visa).