External service disruption: In3

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 17:28 CEST

Investigating

There is an issue with the In3 availability.
Users could experience issues when paying with In3.
We will provide updates as they become available.
Posted Jul 02, 2026 - 16:56 CEST
This incident affected: Pay Later Services (In3).