Login issues Plaza

Incident Report for Buckaroo

Resolved

The issue has been resolved
Posted Feb 25, 2026 - 09:07 CET

Investigating

Users are currently unable to log into the Buckaroo Plaza. We are working on resolving this issue.
Posted Feb 25, 2026 - 08:31 CET
This incident affected: Services & Apps (Plaza).