External disruption: iDEAL (ABN Amro)

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Feb 20, 2025 - 18:14 CET

Identified

There is currently an outage at ABN Amro impacting iDEAL. Users could experience issues when paying with iDEAL.
Posted Feb 20, 2025 - 17:45 CET
This incident affected: Payment methods (iDEAL).