Historical transaction data incomplete

Incident Report for Buckaroo

Resolved

Transactions up to three years ago have been made available in the transaction overview. Further years will be made available over the coming week.
Posted Oct 06, 2023 - 20:16 CEST

Investigating

The transaction overview does not show older historical transaction information. As previously specified, further data will be gradually restored. However, unforeseen circumstances have delayed this process.

We will provide updates as they become available.
Posted Sep 15, 2023 - 10:29 CEST
This incident affected: Services & Apps (Plaza).