External service disruption: iDEAL Rabobank

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 11:22 CEST

Identified

There is an issue with the iDEAL availability of Rabobank.
Users could experience issues when paying with iDEAL.
We will provide updates as they become available.
Posted Jul 02, 2026 - 11:11 CEST
This incident affected: Payment methods (iDEAL).