External disruption iDEAL - SNS ASN & Regiobank

Incident Report for Buckaroo

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 10:54 CEST

Investigating

We have identified an external issue affecting the availability of the iDEAL payment labels—SNS, ASN, and RegioBank. As a result, customers of these banks may experience difficulties when attempting to complete payments via iDEAL.
Posted Jul 28, 2025 - 10:34 CEST
This incident affected: Payment methods (iDEAL).